aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsaturneric <[email protected]>2024-01-30 12:21:46 +0000
committersaturneric <[email protected]>2024-01-30 12:21:46 +0000
commit8874026c55e60600ee6f981966acf79a480a83fb (patch)
tree0f0a6424f25346d580a7f293447bc97fdafd3716 /CMakeLists.txt
parentfix: add general main window rect state fallback logic (diff)
downloadGpgFrontend-8874026c55e60600ee6f981966acf79a480a83fb.tar.gz
GpgFrontend-8874026c55e60600ee6f981966acf79a480a83fb.zip
feat: try to add qt5 support
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 44c64140..2819895f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -64,6 +64,7 @@ option(GPGFRONTEND_BUILD_TYPE_TEST_ALL
"Generate a graphical interface with all functions" OFF)
option(GPGFRONTEND_BUILD_TYPE_STABLE
"Generate release version" ON)
+option(GPGFRONTEND_QT5_BUILD "Swith to Qt5 building mode" OFF)
option(GPGFRONTEND_GENERATE_LINUX_INSTALL_SOFTWARE "Generate an installable version" OFF)
option(GPGFRONTEND_CONFIGURE_FOR_XCODE_BUILD "Generate a version that can be successfully compiled and packaged in Xcode" OFF)
option(GPGFRONTEND_XCODE_TEAM_ID "GpgFrontend Apple Team ID" "NONE")
@@ -330,6 +331,12 @@ else ()
set(APP_INSTALL_FLAG BUNDLE)
endif ()
+if (GPGFRONTEND_QT5_BUILD)
+ add_compile_definitions(QT5_BUILD)
+else()
+ add_compile_definitions(QT6_BUILD)
+endif()
+
# Basic ENV Configure
set(BASIC_ENV_CONFIG 1)
set(QT_MOC_CONFIG 1)