aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsaturneric <[email protected]>2024-07-27 08:56:19 +0000
committersaturneric <[email protected]>2024-07-27 08:56:19 +0000
commit1c4445408577a3bd5743d344cdd31f21d81dc9c0 (patch)
tree18deeb8cac0c66f831c4dd0f9600487c4855cbdf /CMakeLists.txt
parentfix: indirect memory leak issues (diff)
downloadGpgFrontend-1c4445408577a3bd5743d344cdd31f21d81dc9c0.tar.gz
GpgFrontend-1c4445408577a3bd5743d344cdd31f21d81dc9c0.zip
fix: discover and solve some memory issues
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7c3aecc0..8d261fa5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -215,8 +215,8 @@ if(GPGFRONTEND_ENABLE_ASAN)
message(FATAL_ERROR "Use GPGFRONTEND_ENABLE_ASAN only when using the clang compiler.")
endif()
- add_compile_options(-fsanitize=address)
- add_link_options(-fsanitize=address)
+ add_compile_options(-fsanitize=address -fsanitize-recover=address)
+ add_link_options(-fsanitize=address -fsanitize-recover=address)
set(ENABLE_ASAN 1)
endif()